Cross-compilation of OpenCV

"Milk-V Duo is an MPU based on the Altek CV1800B chip, capable of running operating systems based on both LINUX and RTOS. The Altek CV1800B chip features the XuanTie C906 core, known for its powerful processing capabilities. Hence, we attempted cross-compiling the OpenCV image processing library for use with Milk-V Duo. XuanTie’s website ( offers an optimized custom version of OpenCV, believed to maximize the chip’s performance. This version holds great promise.

This is a companion discussion topic for the original entry at

I still have -sh: opencv_example: not found.

I am using the latest DUO image release.

The only only xthread .so in the /lib directory is:
lrwxrwxrwx 1 dhcpcd dhcpcd 37 Oct 21 2023 → …/usr/lib64v0p7_xthead/lp64d/

So, I created the following simlink:
[root@milkv-duo]/lib# ls -l /lib/
lrwxrwxrwx 1 root root 35 Jan 1 00:44 /lib/ → /usr/lib64v0p7_xthead/lp64d/

But I still get the ‘not found’ message?



Never mind. I fixed it:
Simlink for file:///lib/

INTERP 0x0000000000000238 0x0000000000010238 0x0000000000010238
0x000000000000002c 0x000000000000002c R 0x1
[Requesting program interpreter: /lib/]
LOAD 0x0000000000000000 0x0000000000010000 0x0000000000010000
0x0000000000370c38 0x0000000000370c38 R E 0x1000
LOAD 0x0000000000371018 0x0000000000382018 0x0000000000382018

1 Like