New board, problems booting (can only ping for a few seconds, never any ssh)

My first MilkV duo with IOB shield ethernet … stuck, the board gets a DHCP address from my router.
I’ve got a red power light and a flashing blue led.

I can ping the board for a few seconds, then ping stops at a few points during the boot.
I haven’t hooked up a serial port or tried the RNDIS driver (yet).
I’ve tried two different flash cards. the behavior is non-deterministic …

here is an example:

64 bytes from icmp_seq=81 ttl=63 time=97.4 ms
64 bytes from icmp_seq=82 ttl=63 time=117 ms
64 bytes from icmp_seq=83 ttl=63 time=141 ms
– then 100% packet loss, and then way later:
64 bytes from icmp_seq=269 ttl=63 time=1878 ms
64 bytes from icmp_seq=270 ttl=63 time=838 ms
64 bytes from icmp_seq=271 ttl=63 time=260 ms
64 bytes from icmp_seq=272 ttl=63 time=68.0 ms
64 bytes from icmp_seq=273 ttl=63 time=500 ms
64 bytes from icmp_seq=274 ttl=63 time=319 ms
64 bytes from icmp_seq=275 ttl=63 time=195 ms
64 bytes from icmp_seq=276 ttl=63 time=160 ms
– then nothing again.

I’m assuming there is a short in the board and it’s just in an endless reboot cycle.
It is never able respond to ping for more than a few seconds, never able to get SSH up.

You will need to review the serial console output. The default image randomizes the Ethernet MAC, and this may explain some of the symptoms. DHCP on Ethernet may not even be enabled by default on some images.

Additionally the RNDIS driver doesn’t seem to work on Windows 11 insider edition.

At Step 5. The option to select drivers from the local computer does not exist. It can only direct to Windows Update (where the RNDIS driver isn’t an option)

No progress with Linux Ubuntu 22.04 either. Never gets to the final step of renaming usb0, so it’s available for networking.

[3578322.867336] usb 1-9.2: new high-speed USB device number 11 using xhci_hcd
[3578323.155367] usb 1-9.2: device descriptor read/64, error -71
[3578323.363963] usb 1-9.2: New USB device found, idVendor=3346, idProduct=1009, bcdDevice= 5.10
[3578323.363967] usb 1-9.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[3578323.363968] usb 1-9.2: Product: RNDIS
[3578323.363969] usb 1-9.2: Manufacturer: Cvitek
[3578323.363969] usb 1-9.2: SerialNumber: 0123456789
[3578323.366792] rndis_host 1-9.2:1.0 usb0: register ‘rndis_host’ at usb-0000:00:14.0-9.2, RNDIS device, b6:3d:57:d0:0e:5a

In case it’s relevant this was using the latest Duo-V1.0.6

image downloaded from:

Update: Got it working with the serial approach, worked backward and figured out I had a bad CAT6 network cable.

Also the IO Board Ethernet Link lights don’t seem to work.