Serial Console Input not working

Did anybody succeed in logging in to the Duo using the serial console?
I can see it booting without trouble using a serial adapter but it won’t accept input not matter what order I plug it in.

There is a note about this issue at the end of this post Milk-V Duo UART login Terminal Tutorial but I cant make heads or tails of it. I’d really like to use the USB port in host mode, which makes RNDIS not an option.

Details: I tried with the official image and the Arch image. I tried connecting the serial port several seconds after powering up the board. I’ve tested my serial interface with another board (it works).

Hi @Haptony,

It should just work. This works for me for different adapters, boards and builds. You should be able to interrupt the U-Boot process using enter, regardless of the O/S you built. Also strange that you can receive but not send. Sounds like hardware or wiring issue but hard for me to diagnose remotely.

1 Like

Thanks, you’re giving me hope, I’ll try again later.