[Solved] Red and blue light on Milk-V Duo SG2000

Hi, I’ve just plugged my Duo into my laptop via USB-C. I’ve completed the firmware burning from windows: Duo S | Milk-V (milkv.io)

The process completed and I saw the USB download complete message

I was expecting the Duo to reboot and show a blinking blue light. All I saw was a red and blue light on at the same time

I then etched the latest image milkv-duos-sd-v1.1.0-2024-0410.img.zip to a microsd , inserted the sd card , and attempted to boot.

Still I just saw the red and blue light. I also tried switching between ARM and RISCV via the onboard switch. Neither mode resolved the issue

Any ideas?

The device took a little longer to boot than expected - the blue light eventually starts to flash, and I’m able to connect over ssh

it is sometimes handy to have a debug cable connected, you booting up with emmc now ?

I’m still booting from the microsd, thanks for the suggestion

im following the same steps, but no blinking, just constant red/blue lights. How long did you wait?

I had to install the duo’s firmware over usb first. here are the instructions: Duo S | Milk-V

once I’d done that, I could boot the duo. the blue light started flashing after about 10-15 sec

hope that helps