Stuck at the boot screen (Milk V Mars)

I followed the directions here: Download | Milk-V

The only step that I didn’t quite understand was it said to push the boot button. It automatically turns on when you put power to it and I get the white screen with the blue milkv logo, but it just sits there. I did press the little button around the corner of the usb c power port, but nothing happened.

I have tried 2 different sd cards and 2 different computers to write the Fedora image.

1 Like

U posted the download link for milk-v pioneer and not mars. Downloading an flashing the wrong image might be the problem.

My apologies, I too quickly went and grabbed the link for posting without checking.
I’m using the Mars link: Boot the Duo | Milk-V
and the Mars image.

My link was only incorrect in my post, but the problem is the same.

If you don’t have a mouse or keyboard attached, you should connect them. Mine did the same until I added those two devices, then a normal boot sequence to the Debian 11 login screen.

1 Like

Also I am finding that the first boot never gets past the splash screen. I pulled the USB-C and powered it up again and then it booted all the way thru

The button you mentioned is not a boot button, it is the rescue mode button. It is not necessary to press it during normal operation.

When Mars is powered through USB-C, it will start up automatically.

If you have problems such as being unable to enter the system normally when starting Mars, please try to connect a USB-TO-TTL Cable according to the following link to view the system startup log. Send this information to us and that will help us analyze your problem. Thank you.

1 Like

This has worked immediately—I had no mouse connected.

For the record:

  • Mars v1.21
  • Image from GitHub v1.0.6 SD card.

Now first time to see the login screen past the original Milk V splash. Exciting.

1 Like