[Troubleshooting] MilkV Duo Status Light Blinks But Not Showing Up in Device Manager

Hello all!

I purchased a MilkV Duo not too long ago, flashed the image with Balena Etcher, and connected the device via USB-C to my computer (it is a USB A to USB C cable, if that makes a difference). The power light comes on (red, solid) and about 10 seconds later, the status light (blue, blinking) also comes on. It seems to be working, but when I look at Device Manager on Windows 10, there is no detected devices. If I disconnect the Duo, there is no change to the detected devices.

I also tried on Ubuntu–dmesg does not show any RNDIS entries or any entries with “usb0” as the documentation points out.

Is there anything I may be doing wrong? Or is it likely a dead USB interface on the board? Any help is appreciated. Thank you!

You can try replacing the USB cable to test. Some cables only have power supply functionality and lack data transmission functionality.

I have the same problem, the cable that I’m using is the right one.
Over the UART PIN 16/17 I can see that the device is booting up and root prompt is showing up.

I purchased the duo with the cable included and I also had a problem where the network was not seen over the cable and no device appeared under “other” in Device Manager. I did think it odd that the USB-c connector did not seem to seat all the way in the duo receptacle. It just didn’t seem to mate all the way in as you would expect.

The problem ended up being just that. In my over-cautious approach to only applying firm but limited force, I had not fully inserted the cable into the duo. The power LED was on and the lights blinked, but no connection. Applying a bit more firm pressure while carefully providing a little “wiggle” (technical term) and the USB-c male end of the cable snapped into the duo – problem solved.

But, in 57 years of connecting all types of devices – this connection did take quite a bit more effort than most. It worried me, but the fit was indeed just that firm or the snap/tensioning detent that is built into the connector may have been stiffer than most for the initial plug-in. Works like a champ now.

Finesse rather than force saves many unfortunate outcomes…

1 Like

I have never heard of such a thing and specially when speaking of USB-C connection. The action you are explaining will conduct in breading the connector from the board.

Well, as a Registered Professional Engineer (Aero/Mechanical), I can assure you the amount of force and wiggle needed were in fact required and well within the tolerances expected. I’m not sure where you are drawing your speculative “breading[sic] the connector from the board” from – but there was no mention of getting a “bigger hammer” in my post – so the connector should be quite safe :)

1 Like