Trying to make the Duo USB & Ethernet IOB work

The instructions for configuring this board says.

Note that when using the IO-Board, the USB network (RNDIS) is not available, Please use the Ethernet interface on the IO-Board

This is true in that the RNDIS no longer works but On the two boards I have tried no light comes on on the Ethernet port and I can not ping it as

I am guessing that I need to connect using the serial interface header and configure the ethernet but if that is so why does it not tell me in the instructions.

I have tried adding this to my /etc/network/interfaces

auto eth0
iface eth0 inet static

This does not work, still no light on the ethernet.

Anyone got one of these working?

The leds on the ethernet port are not connected.

Check the leds on the other end to see if the ethernet is active.


If your router has the DHCP service enabled by default, after connecting the IOB to the router, an IP will be automatically assigned to the IOB. Can you see the newly assigned IP in the router’s management interface?

1 Like

The lack of LEDs had me confused as well. I saw a little trick on YT. Put a piece of tape on the underside of the board over the USB contacts for the spring pins. This allows you to use both the USB RNDIS and Ethernet at the same time.

Even more confusing, the pinout for the MCU actually shows the driver lines for the two LEDs.

Now I am struggling with setting a static IP on the device. I have the same interfaces file, but it appears to ignore this and use DHCP instead