Where does eth0 on the Duo pickup its settings on startup?

Hi

eth0 isn’t in the interfaces file, and doesn’t appear in scripts in /mnt/system.

What’s the correct/preferred way to set it to your network on startup?

Can you recommend a resource for more reading also? I’d love to understand where eth0 is getting its random IP each start. But I’m clearly not searching the right terms to find this.

Thanks so much, Geoff

2 Likes

After a bit more playing about, trial & error I’m under way. I had no joy having eth0 set by editing the interfaces file. But found running ifconfig down followed by ifconfig up the settings of dhcpcd.conf kicked in. The NIC is now always picking up an IP from DHCP on my network, and the /etc/resolve.conf correctly has the gateway set in it. So that’s a stride forward rather than manually choosing an IP with ifconfig after logging in each time, and it’s the default behavior so there’s no need to find a file to edit

So far I still cannot PuTTY to the Duo using its hostname as I’m not finding it broadcast to the network. Is there a way to achieve this?

Thanks

1 Like

In the list of devices shown on my router, the Duo shows “unknown” in the “Client Name” column, where I’d expect the hostname would be. This might indicate it’s not supplying it when it requests a DHCP lease.

Is this what everyone else is seeing too? Any suggestions on how to remedy this?

Thanks, Geoff

1 Like