Working with GStreamer on duo 64mb

Hi everyone! I’ve been working on adding gstreamer with plugins to create pipeline over RTSP. Built an image using docker container, added gstreamer, it’s plugins and their dependencies. I’ve also added ffmpeg to my image in advance, hoping it will be possible to try it in the future, and some additional stuff (like bash, tar, wget and so on). Complied my image successfully and after booting my Duo board i found it was very slow in responding to my commands. In htop there was a process from /etc/init.d called S99user, that was taking almost 100% of cpu resources. After researching about this binary i found that it is connected with toggling this fancy blue led. There also were error messages in console when i tried to run ./S99user restart by myself, and the problem that arised is that it could not change state of led gpio pin with error like “invalid argument”. After killing this process Duo was fine, but gst-launch and gst-inspect were not working.
I’m actually a completely newbee to embedded linux and gstreamer so i think there might be a problem when i decided to choose all the gstreamer plugins in menuconfig (even bad and ugly ones). Had anyone tried to create custom image for working with gstreamer? Is there proper way to use gstreamer on this board and how can i achieve that? Any suggestions will help, thank you.