Serial assistance

I purchased the Pioneer as a bare motherboard. Like many others thus far, I’m having trouble getting it to boot. The board somewhat helpfully came with a USB serial adapter, but unfortunately the lack of documentation makes troubleshooting with it rather difficult.

The wires for the serial adapter are not labeled. I was able to get some output from the header labeled MCU after some trial and error, with the following details:

Red wire: +5v, connected to the unlabeled pin
White wire: TX
Green wire: RX
Black wire: GND
Baud: 115200

However, the MCU pins just output the following:

firmware build time:Jun 20 2023-11:35:01

EN_VDD_3V3 [O]
EN_DDR01_VPP_2V5 [O]
EN_DDR23_VPP_2V5 [O]
EN_DDR01_VTT_0V6 [O]
EN_DDR23_VTT_0V6 [O]

I never see any output for the pins labeled RISC-V. None of the other pins are labeled, so I’m at a loss for finding useful output to debug the boot process with. Would someone who has gotten helpful serial boot output please give me some pointers on how to properly connect and get helpful output?

In case it’s an issue, I have a single stick of 32GB DDR4-3200 PC4-25600 ECC Registered Memory by NEMIX RAM (HMA84GR7DJR4N-XN) in the topmost slot. This seemed to be the closest RAM to the manufacturer recommended that I could find, and I’m not sure if the slot matters. I have a full set of the officially blessed RAM on the way, but no idea how long it’ll take to ship.

My boot medium is a SanDisk Max Endurance 256GB MicroSD card, and I have a Radeon R5 240 for a GPU. Trying with just the SD card and GPU or just the SD card inserted yields the same results. I don’t have any other PCIEe devices attached, including M.2.

1 Like

I also have trouble getting the board to boot. I have the same output on the MCU console, but nothing on the RISC-V one. What I found a bit suspicious in my case is the output of the current command on MCU:


V_5V = 546(mV)
V_DDR_VDD_0V8 = 534(mV)
V_DDR01_VDDQ_1V2 = 547(mV)
V_DDR23_VDDQ_1V2 = 551(mV)
V_VDD_12V = 594(mV)
V_VDD_EMMC_1V8 = 619(mV)
V_VDD_EMMC_3V3 = 524(mV)
V_VDD_PCIE_C_0V8 = 551(mV)
V_VDD_PCIE_D_0V8 = 561(mV)
V_VDD_PCIE_H_1V8 = 594(mV)
V_VDD_PLL_0V8 = 582(mV)
V_VDD_RGMII_1V8 = 581(mV)
V_VDDC = 563(mV)
V_VDDIO18 = 600(mV)
V_VQPS18 = 0(mV)
temp:soc:26 Cel board:20 Cel

Maybe someone who got the board working could post the output of that command.

I tried different memory kits

  • Kingston KVR24R17D4K4/128, 2400 MT/s, DDR4 ECC Reg CL17 2Rx4
  • Kingston KSM32RD8/32HCR, 3200 MT/s, DDR4 ECC Reg CL22 2Rx8
  • Kingston KSM32RD4/32HDR, 3200 MT/s, DDR4 ECC Reg CL22 2Rx4
  • Corsair CMK32GX4M2D3600C18, 3600 MT/s, DDR4 UDIMM, CL18 2Rx?

which did not work. Note @MrDrMcCoy the docs page says you should install a single stick in the bottommost slot no the topmost. Please keep us updated if you get it to work with the “officially blessed” memory.

1 Like

I ordered the bare board and I have been able to get it to boot successfully.
I am using 128 GB (4 X 32GB) of Micron 2Rx4 PC4-3200AA-RE4-12 Registered ECC memory.
When I plug the AC power cord in to the power supply, the board boots. (Of course I prepared the SD card image, as described in “getting started” first.) It does take a while to boot, so at first I didn’t think it was doing anything, as the boot console output comes out of the risc-v serial port and the screen is off until the graphical Linux desktop loads.
There have been a few times that it powers on but never seems to boot. I have found that if I unplug the AC power, wait for all LEDs on the board to go out, then wait at least another 30 seconds, then plug the AC power back in, the board will automatically power back on and boot successfully.
I am attempting to collect info from both debug serial ports simultaneously and see what’s going on.

1 Like

Also, on the mcu debug serial port (the output of which you showed), you can type ‘help’ for some additional commands. There are useful commands for powering on, off, reboot, as well as the mcu and arm subsystems.

1 Like

On my currently not booting motherboard I also get similar voltag readings (press return to get the ‘#’ prompt on the MCU connector)

# current
V_5V = 607(mV)
V_DDR_VDD_0V8 = 567(mV)
V_DDR01_VDDQ_1V2 = 573(mV)
V_DDR23_VDDQ_1V2 = 552(mV)
V_VDD_12V = 637(mV)
V_VDD_EMMC_1V8 = 621(mV)
V_VDD_EMMC_3V3 = 536(mV)
V_VDD_PCIE_C_0V8 = 612(mV)
V_VDD_PCIE_D_0V8 = 581(mV)
V_VDD_PCIE_H_1V8 = 542(mV)
V_VDD_PLL_0V8 = 591(mV)
V_VDD_RGMII_1V8 = 549(mV)
V_VDDC = 586(mV)
V_VDDIO18 = 633(mV)
V_VQPS18 = 0(mV)
temp:soc:31 Cel board:25 Cel
# current
V_5V = 582(mV)
V_DDR_VDD_0V8 = 525(mV)
V_DDR01_VDDQ_1V2 = 538(mV)
V_DDR23_VDDQ_1V2 = 526(mV)
V_VDD_12V = 614(mV)
V_VDD_EMMC_1V8 = 581(mV)
V_VDD_EMMC_3V3 = 509(mV)
V_VDD_PCIE_C_0V8 = 587(mV)
V_VDD_PCIE_D_0V8 = 548(mV)
V_VDD_PCIE_H_1V8 = 507(mV)
V_VDD_PLL_0V8 = 560(mV)
V_VDD_RGMII_1V8 = 522(mV)
V_VDDC = 562(mV)
V_VDDIO18 = 599(mV)
V_VQPS18 = 0(mV)
temp:soc:35 Cel board:33 Cel

The values fluctuate but I suspect these are the raw values read from a A2D with a range of 0-1023 counts and we don’t have the scaling resistor values to see what the actual measured voltage is. But if that’s correct and the A2D is Vref = 1.8 then the 1.2V rails for DDR VDDQ are off by quite a bit and why are PCIE C, D implied as 0.8V? but H is 1.8V? Makes no sense…

However, what does concern me is the last voltage V_VQS18 which always reads as 0 I wonder if that voltage rail is shorted.

I haven’t tried the unplug and discharge for 30 seconds procedure yet. I also have my single DIMM in the “bottom” slot closest to the PCI not the top slot.

Someone mentioned that they used the front panel USB-C to get serial console by setting up baud rates. That would imply that unlike the MCU connector, the RISC-V connector might actually be USB signalling? Anyone measured the voltages on those pins? Maybe there is an on-board FTDI chip to provide the RISC-V serial interface.

1 Like

No, both the debug ports on the motherboard are serial. 115200 baud 8N1, no flow control. I purchased the bare board but I am guessing that if you bought the “full case” / turnkey system, it has a USB-to-serial cable already installed, with the USB end presented as a USB-C connector on the front case.

My voltage readings are about the same as yours, including V_VQPS18 = 0(mV), and my board works fine. So I don’t think that’s a problem. The mV readings for all the various voltages are too close to each other, so I am guessing that each one has its own “custom” resistor divider before going into the ADC. Maybe when the schematics are published we can figure that out. I don’t know if it’s really supposed to be measuring “current” (as the command would imply), or voltage…

I would suggest tying “help” and trying the various power* commands. On my board, sometimes it boots when I plug it in, and other times I have to issue “poweron” or “poweron_rv”.

1 Like

I think “current” is meant as moment in time

1 Like

Thanks for confirming the VQPS18 reading as “normal” and the wiring on the RISC-V

I downloaded the 2023-05-xx image but that appears to be known buggy and I need to replace it with the 2023-11-xx image as that apparently has a good boot loader. Maybe then, I’ll get some output on the RISC-V header. Haven’t seen anything there yet.

I also have the bare motherboard and put my own memory (Samsung) and SDCARD (SanDisk) in.

1 Like

I posted my hardware in

1 Like

not quite - I also got the board only and there is actually a CP210x on the board, right above the USB 3.0 front panel header. So when you plug a front-panel USB 3.0 into this, you can get this onboard USB UART to work using a USB A-to-A cable. VBUS is needed here, so you don’t need an isolated USB A-to-A cable at least…


That’s interesting. So I guess there is more than one way to connect? Which port does the CP210x service, mcu or risc-v? At any rate, I am using the two 4-pin headers in the bottom right corner, each with its own USB-to-serial cable.

1 Like

I assume the RISC-V, I don’t see any MCU output

1 Like